Разместите свой проект бесплатно и начните получать предложения от фрилансеров-исполнителей уже спустя минуты после публикации!
3000 ₽

Отладка модуля ПВЗ в корзине с яндекс-картами . Опенкарт 1.5.3

истекло время актуальности


В корзину интегрирован модуль ПВЗ и доработан под условия и стоимость доставки. Несколько лет модуль работал хорошо, но то ли зацепили мы при других доработках, а скорее всего у яндекса изменились API. 

В общем , при некоторых вариантах переключения в корзине условий ( т.е. доставка курьером или в ПВЗ , смена региона доставки и интервала) карта с ПВЗ начинает залипать , т.е. не работает зум и перемещение по карте с помощью зажатой ЛКМ. Ощущение , что ценетрируется карта и не реагирует на выбор различных ПВЗ, на зум и ползунки.

Но если обновить браузер ( F5 или кнопкой браузера) , то ошибка исчезает и карта начинает двигаться и все работает.. до очередной краш комбинации

Наш программист по поддержке сайта не смог разобраться - сказал , проблема с позиционированием точки. при выборе активная точка должна быть по центру, но она не обрабатывается ...

Делайте ставки , если понимаете в чем может быть проблема и в личку скину уже сайт и как воспроизвести ошибку ( комбинацию условий , при которых возникает ошибка)




  1. 1 день3000 ₴
    Игорь Привалов
     147 

    Готов взяться за работу, если сайт есть в публичном доступе, прошу кинуть для уточнения.

    Украина Черновцы | 17 марта в 17:49 |